Pourquoi l'affichage des pages du site est si long?

  • Réponses :50
  • OuverteNon stickyRépondu
  • Posts de Forum 3 950

25 juil. 2017 à 21:12:34 via site

Bonjour,
J'ai remarqué que les pages du site (aussi bien les news que le forum) sont très longs à s'afficher depuis Google Chrome sous windows7 (w7 64bits) depuis 2 mois environ. ça concerne aussi chromium et IE.
J'ai fais des tests dans deux configurations: avec et sans adblocker.
Dans le premier cas, j'ai un page blanche pendant 3 à 5 s quand je clique sur un lien, mais l'affichage est immédiat quand je change de page dans un post, ou après avoir validé ma réponse.
J'en suis arrivé au point que, souvent quand je commence à taper une réponse, je n'ai plus la main ou bien, ce que je tape s'affiche à retardement, puis je peux poursuivre la saisie.
Je n'ai plus ce problème quand je désactive le javascript pour le site ou que j'active mon adblocker.

Dans le deuxième cas, j'ai la pub, l'affichage est quasi-immédiat. Mais la page n'arrête pas de se recharger (je vois le bouton refresh qui affiche constamment une petite croix clignotante au lieu du signe reload). je pense que c'est la faute d'un javascript qui rafraîchit la page en permanence.
Est-ce que les devs confirment?
A côté de ça, sous Android (sur mon téléphone), ça charge immédiatement sous chrome, mais quand j'ai une notification pour un "merci", celle-ci disparaît presque tout de suite sans que j'ai le temps de cliquer dessus. (s'affiche un quart de seconde et disparaît)
Ce n'était pas le cas auparavant.
J'aimerais savoir si d'autres utilisateurs ont le même problème.

Luna

Répondre
Luna
  • Mod
  • Posts de Forum 44 825

25 juil. 2017 à 21:47:10 via app

Est ce que les dev confirment ?
Faudrait qu'ils commencent à faire la MAJ de l'application.
C'était quand la dernière MAJ?

— Modifié le 25 juil. 2017 à 22:09:09

Keep Calm and Love Android.

Répondre
  • Posts de Forum 3 950

25 juil. 2017 à 22:58:41 via site

Luna

Est ce que les dev confirment ?
Faudrait qu'ils commencent à faire la MAJ de l'application.
C'était quand la dernière MAJ?

euh... tu me poses la question? je ne fais parti de la team, et je ne sais même pas développer sous Android.
Mais je suspecte qu'il y ait eu des modifications dans le javascript du site.

Luna

Répondre
Luna
  • Mod
  • Posts de Forum 44 825

25 juil. 2017 à 23:14:57 via app

Je te confirme que je n'ai rien remarqué.
Mais c'est peut-être aussi à cause de ma médiocre connexion.

Keep Calm and Love Android.

Répondre
  • Posts de Forum 3 950

25 juil. 2017 à 23:26:47 via site

tu penses qu'il n'y a pas de pub?
Alors tu dois avoir un ad blocker natif sur ta tablette.

Voici un bout de code de cette page.

<div id="ad_mpu_mobile" 
       class="idgGoogleAdTag
               tabletBanner mobileBanner site-header-ad" 
       data-adunit-fir="true"
       data-idg-sizes="[[300,50],[320,50]]"></div>

Partout dans les blocs de class "idgGoogleAdTag" s'affiche une pub animée.
Un exemple de ce qu'on peut y trouver:
http://cstatic.weborama.fr/advertiser/1215/167/1489/2180/index.html?scrrefstr=scr_98066465896banner1501017508970&scrdebug=0&scrwidth=728&scrheight=90&scrwebodomain=0&scrdevtype=desktop&vars=wuid%3D%26retargeting%3D%26

— Modifié le 25 juil. 2017 à 23:27:32

Luna

Répondre
Luna
  • Mod
  • Posts de Forum 44 825

25 juil. 2017 à 23:31:32 via app

Donc tu penses que les pages sont plus longues à cause de la pub.

Keep Calm and Love Android.

Répondre
  • Posts de Forum 3 950

25 juil. 2017 à 23:56:15 via site

C'est ce que j'ai constaté. Certains bandeaux publicitaires perturbent l'affichage.
Il faudrait vérifier auprès d'autres utilisateurs, sous windows (différentes versions), sous android.
Le moteur javascript de Chrome aussi évolue.

Luna

Répondre
  • Posts de Forum 3 950

26 juil. 2017 à 19:50:19 via site

@Luna, après lecture du post des solutions pour Chrome:
- Je n'ai pas vidé le cache, j'ai désinstallé chrome, supprimé le répertoire d'install de chrome et installé chromium (suppression des cookies, cache, bookmark, données d'applis chromes et extension).
Aucun changement de comportement du navigateur.
- je n'active pas l'économiseur de données.
J'ai déjà fait des tests quand tout allez bien. Je ne gagne pas grand chose en temps de chargement.
ça marche bien pour le texte et les css hypertrophiées qui seront transférées plus rapidement. Mais avec une connexion rapide, le bénéfice est gommé.
Par contre, avec un processeur faiblard, le chargement sera un peu plus long (décompression oblige)
La plupart des sites que je visite on beaucoup d'images. (les jpg seront peu compressés par cette technique)
ça reste intéressant pour économiser de la data sur mobile. Mais les forfaits sont très généreux, alors ça perd de son intérêt.
- J'ai désactivé le service de prédiction pour m'assurer que ça ne perturbait ni ne ralentissait le chargement de la page en cours de lecture.
- désactiver javascript a résolu le problème, sauf que certaines fonctionnalités du PIT ne marchent plus sans.
- pour les flags, j'ai fait quelques tests, mais je ne vois pas de différence. ça prendrait trop de temps et puis ça peut marcher pour un site et foirer l'affichage des autres. Alors je préfère garder des paramètres par défaut.

Le problème est bien identifié.
Sans javascript, pas de pub.
Je suppose que l'adblocker change des styles et/ou bloque l'exécution de certains scripts, avant d'afficher la page.
J'ai trouvé un fix, à défaut d'une solution: injecter un bout de css pour masquer la pub sur un site en particulier dans chrome, et désactiver le bloqueur de pub.
ça marche sous windows avec chrome, pas IE, ni firefox et pas sous android non plus.

— Modifié le 26 juil. 2017 à 19:53:41

K-portLuna

Répondre
Luna
  • Mod
  • Posts de Forum 44 825

26 juil. 2017 à 20:27:28 via site

J'ai trouvé un fix, à défaut d'une solution: injecter un bout de css pour masquer la pub sur un site en particulier dans chrome, et désactiver le bloqueur de pub.
ça marche sous windows avec chrome, pas IE, ni firefox et pas sous android non plus.

Par conséquent utiliser un navigateur comme Opéra ou un autre ça ne résoudra pas non plus ce ralentissement.

— Modifié le 26 juil. 2017 à 20:28:00

Keep Calm and Love Android.

Répondre
  • Posts de Forum 3 950

26 juil. 2017 à 21:37:59 via site

Luna

Par conséquent utiliser un navigateur comme Opéra ou un autre ça ne résoudra pas non plus ce ralentissement.

Je n'ai pas essayé.

Luna

Répondre
Luna
  • Mod
  • Posts de Forum 44 825

26 juil. 2017 à 21:45:36 via site

Super, on va tous les tester.

Et si on commençait par Opéra?

Keep Calm and Love Android.

Répondre
Compte désactivé
  • Posts de Forum 1 185

27 juil. 2017 à 11:01:59 via site

C'est exactement ce que je rapportais il y a 10 jours , page blanche pendant 3 secondes mais Luna disait qu'une attente de 3 secondes c'était merveilleux par rapport à ce qu'elle avait avec sa connexion internet à la mord moi le noeud .(laughing)

Bref ça me fait ça avec la fibre sous firefox et sur mobile en 4 G plus. Ca m'agace.

skyrail

Répondre
Luna
  • Mod
  • Posts de Forum 44 825

27 juil. 2017 à 11:18:21 via site

@ Tiguan

Ah, ah ,ah ....j'ai été éclairé une fois de plus...LOL
Je suis entrain de tester deux navigateurs présentés comme super rapide , opéra pour Android beta et l'autre c'est firefox Focus.
Et alors ?
Ils sont vraiment plus rapide , ils font vraiment ce qu'ils disent, voilà ça arrive.
Il y a encore de l'espoir , une meilleure connexion est possible , il ne fallait abandonner.
Du coup je vais tous les tester .

Keep Calm and Love Android.

Répondre
  • Posts de Forum 3 950

27 juil. 2017 à 12:32:26 via site

[[cite Luna]]
Depuis hier que je suis dessus, je trouve qu'il est plus rapide que Chrome.

Alors? la page s'affiche en 2 ou 3 s ? (thinking)

Luna

Répondre
  • Posts de Forum 3 950

27 juil. 2017 à 12:34:27 via site

[[cite Luna]]
Je suis entrain de tester deux navigateurs présentés comme super rapide , opéra pour Android beta et l'autre c'est firefox Focus.
Et alors ?
Ils sont vraiment plus rapide , ils font vraiment ce qu'ils disent, voilà ça arrive

Chrome vient de passer à la version 60.
Mais, je pense qu'il n'y a rien à attendre (pour windows) en terme d performances.

Luna

Répondre
  • Posts de Forum 3 950

27 juil. 2017 à 12:37:33 via site

Tiguan

C'est exactement ce que je rapportais il y a 10 jours , page blanche pendant 3 secondes mais Luna disait qu'une attente de 3 secondes c'était merveilleux par rapport à ce qu'elle avait avec sa connexion internet à la mord moi le noeud .(laughing)

Bref ça me fait ça avec la fibre sous firefox et sur mobile en 4 G plus. Ca m'agace.

Merci Tiguan pour le retour.

LunaCompte désactivé

Répondre
Luna
  • Mod
  • Posts de Forum 44 825

27 juil. 2017 à 13:14:21 via site

@ Skyrail

  • De 2 à 3 secondes exactement sur Opéra pour Android Bêta.

Keep Calm and Love Android.

Répondre
  • Posts de Forum 451

27 juil. 2017 à 14:25:07 via site

J'aurais plutôt accusé la forte affluence du site...

On peut se tromper, mais l'erreur est humaine

Répondre
Luna
  • Mod
  • Posts de Forum 44 825

27 juil. 2017 à 14:30:30 via site

@ abou

Ma connexion est plus rapide sur Opéra , j'ai gardé Chrome pour comparer.
Et en ce moment avec Firefox Focus , un navigateur de seulement 10MO je vais encore plus vite.

— Modifié le 28 juil. 2017 à 12:08:11

Keep Calm and Love Android.

Répondre
  • Posts de Forum 3 950

27 juil. 2017 à 14:40:00 via site

Aboubacar G.

J'aurais plutôt accusé la forte affluence du site...

Je n'ai pas remarqué un afflux massif de visiteurs entre avant et après ce problème de page blanche. Et d'ailleurs, quand javascript est désactivé, l'affichage est ultra-rapide. Quand le bloc incluant la pub est supprimé, il n'y a pas d'attente perceptible. je pense que c'est la frame qui est dans la pub, et qui se rafraîchit en permanence, qui ralentit le chargement complet de la page.

Luna

Répondre
  • Posts de Forum 3 950

27 juil. 2017 à 14:40:57 via site

Luna

@ Skyrail

  • De 2 à 3 secondes exactement sur Opéra pour Android Bêta.

c'est encore trop.

Luna

Répondre
Luna
  • Mod
  • Posts de Forum 44 825

27 juil. 2017 à 16:34:42 via site

@ Skyrail

Je n'aurais jamais aussi bien que toi dans ma zone.
Je peux améliorer ma connexion, mais je ne peux pas la transformer à ce point là.

Par contre sur Firefox Focus, j'arrive à encore améliorer ma vitesse.
Il faut vraiment que tu la test, sur ton S5.

Keep Calm and Love Android.

skyrail

Répondre
  • Posts de Forum 3 950

28 juil. 2017 à 22:27:25 via site

C'est de pire en pire. Maintenant ça met entré 3 et 5s pour afficher une page dans chrome sous Android. :(
Et toujours ce problème de notification furtive pour afficher un merci. :?

Répondre
  • Posts de Forum 451

28 juil. 2017 à 22:44:04 via site

Pour moi c'est l'inverse, le site n'envoie presque jamais de notification pour m'informer des nouveaux postes dans mes topics favoris.

On peut se tromper, mais l'erreur est humaine

Répondre
  • Posts de Forum 3 950

2 août 2017 à 16:19:24 via site

De plus en plus lent (3-4 s pour afficher une page) cette fois sous Android, avec la pub et sans adblocker. :(

Répondre
  • Posts de Forum 451

2 août 2017 à 20:33:54 via site

Et si on télécharge la page en hors connexion pour déterminer l'origine du problème.

On peut se tromper, mais l'erreur est humaine

Répondre
  • Posts de Forum 3 950

3 août 2017 à 18:11:19 via site

je sais pas trop quelle version de Chrome j'utilise sous Android.
mais je fais parti d'un programme de test.

Répondre
Luna
  • Mod
  • Posts de Forum 44 825

3 août 2017 à 18:21:54 via site

je sais pas trop quelle version de Chrome j'utilise sous Android.

C'est facile, il y en a 4 :

  • Chrome
  • Chrome Bêta
  • Chrome Dev
  • Chrome Canary

Les adblocks ce ne sont pas une bonne solution pour Android, mais le trop de pub à la limite du malware ce n'est plus possible .
Google test une solution neutre.
Je trouve que c'est une bonne idée sur le papier, après .....

Keep Calm and Love Android.

Répondre
  • Posts de Forum 3 950

3 août 2017 à 18:49:25 via site

oui, mais ça ne concerne que chrome. Comment je fais alors pour les autres applis qui adorent la pub?

Répondre
Luna
  • Mod
  • Posts de Forum 44 825

3 août 2017 à 18:52:23 via site

Tu gardes celles qui savent bien doser et tu désinstalles les autres.
Il faut favoriser les développeurs qui ont une bonne conduite et pas les autres.
Et ne t'inquiète pas ils sont nombreux " les bons développeurs "

— Modifié le 3 août 2017 à 18:53:22

Keep Calm and Love Android.

Répondre
  • Posts de Forum 3 950

3 août 2017 à 19:23:21 via site

@Luna je suis allergique à la pub, ça me distrait.
Pour le choix des applis, je prend celle qui rendent le service recherché. Et si je trouve mieux ou recouvrent plusieurs services, alors j'en change.
Mais si une appli fait ce que je demande et q'elle devient trop difficile à utiliser à cause des écrans de pub, ralentissements... alors je cherche autre chose, même si c'est celle qui fait le meilleur job.
Parfois, je la garde, parce que j'utilise peu. J'ai clean master dans un coin qui me rend chaque fois un fier service en situation de crise.

Répondre
  • Posts de Forum 3 950

4 août 2017 à 13:12:10 via site

ça devient pénible, sur Chrome pour windows, ces pages qui continuent à s'auto-charger en permanence alors que tout est affiché.
En conséquence, mon cpu monte à 80% en continu et ça ralentit à mort.
Je ne sais pas quel javascript provoque ça sur le site. Notez que j'ai désactivé l'ad blocker pour Androidpit.
La meilleure solution pour le moment est d'enfoncer la touche escape pendant quelques secondes, juste après le chargement complet.
Avec un peu de chance le javascript de pub ne s'exécutera pas.
Sous Android, cette manip n'est pas possible, j'ai un écran blanc de quelques secondes avant de voir le contenu.

Je comprend mieux pourquoi les modos espacent leurs interventions.

Répondre
Luna
  • Mod
  • Posts de Forum 44 825

4 août 2017 à 14:40:55 via site

Je comprend mieux pourquoi les modos espacent leurs interventions.

De quels modos tu parles ?
Tu es sur le site des bidouilleurs ou sur l'Autre 🤢

Keep Calm and Love Android.

Répondre
  • Posts de Forum 3 950

4 août 2017 à 16:42:39 via site

Luna

Je comprend mieux pourquoi les modos espacent leurs interventions.

De quels modos tu parles ?
Tu es sur le site des bidouilleurs ou sur l'Autre 🤢

:?(thinking)
où crois-tu qu'on soit?

Répondre
Luna
  • Mod
  • Posts de Forum 44 825

4 août 2017 à 16:48:51 via site

où crois-tu qu'on soit?

Sur un site sans modérateur actif.
Concrètement j'en vois jamais un.

Keep Calm and Love Android.

Répondre
Luna
  • Mod
  • Posts de Forum 44 825

1 sept. 2017 à 10:01:45 via site

Est ce que tu as résolu ton problème , parce que moi j'ai des pages d'erreurs presque toute les semaine qui me bloque l'accès au site.
" nos serveurs rencontrent des problèmes"
Connecter vous sur votre compte Twitter pour en savoir plus.
Je n'ai pas de compte Twitter, je ne savais pas que c'était lui le modérateur du site.
Je n'ouvrirai pas de compte comment ce fait il qu'on m'y oblige.

— Modifié le 1 sept. 2017 à 10:03:09

Keep Calm and Love Android.

skyrail

Répondre
  • Posts de Forum 3 950

1 sept. 2017 à 19:35:38 via site

Luna

Est ce que tu as résolu ton problème ,

non.
La pub se charge. L'affichage est ralenti.

parce que moi j'ai des pages d'erreurs presque toute les semaine qui me bloque l'accès au site.

Pas de bug chez moi. Enfin, c'est limite. ça affiche une page blanche pendant environ 3 à 5 s, Et parfois, il y a un message "pas de connexion" ou un truc dans le genre en bas pendant un bref instant et le contenu apparaît.

" nos serveurs rencontrent des problèmes"
Connecter vous sur votre compte Twitter pour en savoir plus.

Rien de tout ça.

Luna

Répondre
Luna
  • Mod
  • Posts de Forum 44 825

13 sept. 2017 à 19:02:09 via site

J'ai la photo du modérateur du site 🗽

  • Il est bleu et il vole (hug)

(danger) sauf que moi l'humain Luna ne peux pas lui poser des questions , je ne parle pas le Piaf (thinking) ...cuicui ça n'a pas marché :'(

image

Alors est-ce que toi l'humain Skyrail tu as ce genre de bug ?

😒 ....tu es bien un humain , hein ?

Keep Calm and Love Android.

skyrail

Répondre
  • Posts de Forum 3 950

13 sept. 2017 à 19:25:22 via site

Luna

Alors est-ce que toi l'humain Skyrail tu as ce genre de bug ?

😒 ....tu es bien un humain , hein ?

bol bot ... bolt (*)

oui j'ai eu "interruption des programmes", jste après une coupure réseau que je n'ai résolu qu'après 45min de tests sur les CPL.
Alors, je ne sais pas trop si c'est lié au site ou à ma connexion internet perdue.

Depuis quelques heures aussi, j'ai réactivé mon adblocker, après plusieurs semaines sans. Depuis 3 jours je suis repassé de chromium à chrome. Et je constate que les temps d'affichage d'AP sont revenus à la normale sur PC.
Les liens vers les commentaires aussi semblent fonctionner correctement.
Une correction a été faite je pense.

Compte désactivé

Répondre
  • Posts de Forum 451

17 sept. 2017 à 03:03:10 via site

Pourquoi mon wifi 5Ghz est moin puissant que mon wifi 2,4 ghz allors qu'il un débit plus élevé?

On peut se tromper, mais l'erreur est humaine

Répondre
Compte désactivé
  • Posts de Forum 1 185

17 sept. 2017 à 16:04:27 via site

Pour ma part tout est redevenu instantané depuis ce matin , fini l'attente de 3 secondes .

Répondre
Luna
  • Mod
  • Posts de Forum 44 825

17 sept. 2017 à 16:28:11 via site

Pour ma part tout est redevenu instantané depuis ce matin , fini l'attente de 3 secondes .

Lol 3 secondes quand je trouve que c'est super rapide en 20 secondes. :'(

Keep Calm and Love Android.

Répondre
  • Posts de Forum 3 950

17 sept. 2017 à 17:12:33 via site

Luna

Pour ma part tout est redevenu instantané depuis ce matin , fini l'attente de 3 secondes .

Lol 3 secondes quand je trouve que c'est super rapide en 20 secondes. :'(

sors de ta caverne Luna, 20s, euh 4s la durée du zapping, c'est pour canalsat avec son cube, pas pour le forum.

Répondre
Luna
  • Mod
  • Posts de Forum 44 825

28 sept. 2017 à 19:01:03 via site

J'ai un nouveau problème.
Je n'arrive plus à poster d'images depuis mon smartphone mais que depuis le chromebook de mon fils et ça fait plus de trois jours que ça dure.
Ça me ralenti énormément et je n'ai pas Twitter.
Est-ce que tu as des infos la dessus?

— Modifié le 28 sept. 2017 à 19:02:23

Keep Calm and Love Android.

Répondre
Luna
  • Mod
  • Posts de Forum 44 825

28 sept. 2017 à 22:07:35 via site

@ Skyrail

Je sais que tu es là , arrête de te cacher !
Alors pourquoi je n'ai plus le droit de poster des images ?

Keep Calm and Love Android.

Répondre
  • Posts de Forum 3 950

28 sept. 2017 à 22:23:53 via site

Luna

J'ai un nouveau problème.
Je n'arrive plus à poster d'images depuis mon smartphone mais que depuis le chromebook de mon fils et ça fait plus de trois jours que ça dure.
Ça me ralenti énormément et je n'ai pas Twitter.
Est-ce que tu as des infos la dessus?

Je n'ai aucune info à ce sujet Luna.
Excuses-moi, je suis occupé sur d'autres problématiques.
D'après ce que tu exposes, je dirais que le problème est sur ta tablette.
Essaies avec une autre navigateur, ou en mode mobile, puis bureau, ou encore navigation privée.
On en saura un peu plus.

image

Répondre
Luna
  • Mod
  • Posts de Forum 44 825

28 sept. 2017 à 22:54:37 via app

le problème dure depuis presque une semaine sur mon smartphone et trois jours sur ma tablette.

Vous voulez quoi exactement que j'arrête ?
Personne n'est donc capable d'écrire un message privé , moi j'y arrive mais on ne me réponds jamais 😶 hasard ou coïncidence?

Il y aurait donc eu des signes ....en attendant je vais attendre de voir qui sera capable décrire un message en privé !

— Modifié le 28 sept. 2017 à 22:57:10

Keep Calm and Love Android.

Répondre