Installer CyanogenMod 10.1 / Android Jelly Bean sur le Galaxy S

  • Réponses :138
  • OuverteStickyNon répondu
  • Posts de Forum 1 952

15 juil. 2013 à 17:24:31 via site

Topic officiel de discussion suite au tutoriel :
Installer CyanogenMod 10.1 sur le Samsung Galaxy S

Répondre
  • Posts de Forum 20

15 juil. 2013 à 17:39:38 via site

resalut,
merci pour ton temps,

bon le tel est planté :-(

j'ai suivi le tuto, j'ai mis le fichier cm-10.1.0-galaxysmtd à la racine de mon tel (c'est peut etre ca le pb ?)

j'ai téléchargé les fichier mentionnés sauf l'appli gmail (le dernier module mais je pense pas bien grave)
fait les premiers steps jusqu'au
5. Sélectionnez maintenant Install zip from sdcard, puis choose zip from sdcard
6. Sélectionnez le fichier de la rom (cm-10.1.0-galaxysmtd.zip), puis validez avec Yes

mais lorsque j'ai fait le 5 je n'ai pas pu faire 6 car pas de file trouvés

je n'ai pas rebooté mon tel car j'ai un peu peur du coup de ne pouvoir rattraper

si tu es sur un IM ca sera peut etre plus simple si tu peux (je suis sur google karimaumjaud@gmail.com)

Répondre
  • Posts de Forum 20

15 juil. 2013 à 18:04:53 via site

oui j'ai placé le .zip sur le tel à la racine.
et oui le custom a bien fonctionné (premiere fois n'a pas marché, j'ai recommencé la même manip et il est passé en successfull

puis j'ai relancé comme indiqué fait les 5 premieres étapes et pas de file.

dans le menu il y a mounts and storage
je suis entré dedans ensuite fais le mount USB storage
puis de mon PC je vois encore le fichier cm-10.1.0-galaxysmtd.zip

Répondre
  • Posts de Forum 20

15 juil. 2013 à 18:16:16 via site

j'ai retéléchargé

"retente de le flasher" = je remount le tel sur mon PC depuis l'utilitaire de l'étape Installation de CyanogenMod 10.1

ou je reboot le tel et recommence tout ?

Répondre
  • Posts de Forum 1 952

15 juil. 2013 à 18:18:15 via site

karim aumjaud
j'ai retéléchargé

"retente de le flasher" = je remount le tel sur mon PC depuis l'utilitaire de l'étape Installation de CyanogenMod 10.1

ou je reboot le tel et recommence tout ?

Tu remplaces l'ancien fichier par le nouveau via mount & storage, puis tu retentes l'opération.

Répondre
  • Posts de Forum 20

15 juil. 2013 à 18:21:09 via site

pareil

j'ouvre bien le fichier depuis windows sur mon PC il a l'air d'etre ok donc.
le transfert vers le tel fonctionne, mais "No files found"

Répondre
  • Posts de Forum 20

15 juil. 2013 à 19:53:52 via site

on est bien d'accord pour qu'il faut mettre le fichier directement sur la racine (même emplacmeent que devicefriendlyname.txt)

Répondre
  • Posts de Forum 20

16 juil. 2013 à 09:59:29 via site

si tu as une autre idée suis preneur (ou un moyen re restaurer une autre version)
j'ai laissé le tel allumé sur le menu pour ne pas l'eteindre / rebooter ou quoi ce soit, car je ne connais pas bien.

pour le moment j'ai refait l'étape 2 fois tjrs pareil (en ayant télécharger de nouveau le fichier)

Répondre
  • Posts de Forum 20

16 juil. 2013 à 10:35:23 via site

hello
je fais "install zip from sdcard" puis "choose zip from sdcard" et j'ai directement "no files found" pas la possibilité de choisir un autre emplacement.
par contre si je fais "apply /sdcard/update.zip" il me met :
- No
- No
...
- Yes - Instal / sdcard/update.zip
- No
...

si je renomme en update.zip ca peut marcher ou vu que c'est un package complet il ne vaut mieux pas tester ?

Répondre
  • Posts de Forum 20

16 juil. 2013 à 10:48:14 via site

j'ai créé le répertoire sdcard car il n'existant pas .... directement à la racine du tel (enfin directement à la racine de l'attechement disk lorsque je connecte le disk en USB ... j'ai supposé que c'était la racine du tel ... peut etre est la le pb ?)
j'ai renommé cm-10.1.0-galaxysmtd.zip en update.zip
et lancé "apply /sdcard/update.zip"

réponse :
-- Installing: /sdcard/update.zip
Finding update package....
Opening update package....
E:Can't open /sdcard/update.zip
(No such file or directory)
Installation aborted

comprends pas trop pourquoi depuis le PC je vois bien les fichiers ...

Répondre
  • Posts de Forum 20

16 juil. 2013 à 10:57:09 via site

Je n'en ai pas
j'essaye de voir si un collègue en aurait une ....
mais ca veut dire que je dois éteindre le tel ? ce n'est pas un pb ?

Répondre
  • Posts de Forum 20

16 juil. 2013 à 11:36:41 via site

et les étapes la :
Si vous avez bien suivi, vous êtes donc en mode custom recovery
2. Commencez par faire un backup NANdroid. Pour ce faire, déplacez le curseur avec les boutons de volume jusqu'à backup & restore et validez avec power
3. De la même façon, sélectionnez backup
4. Une fois la sauvegarde terminée, sélectionnez wipe data/factory reset, puis validez avec Yes

Pas de microSD dispo pour le moemnt

Répondre
  • Posts de Forum 1 952

16 juil. 2013 à 11:51:45 via site

Attends, je pense à quelque chose, quand tu vas dans mount & storage, en face de la SD card, tu as "unmount" ?
Si oui, clique dessus. Ton smartphone ne peux peut-être pas y accéder car elle est montée, il faut la "démonter" pour cela.

Répondre
  • Posts de Forum 20

16 juil. 2013 à 11:57:49 via site

non elle est unmount, il affiche
mount /sdcard
mount /system

seul /cahce est en unmount
...

— Modifié le 16 juil. 2013 à 11:58:38

Répondre
  • Posts de Forum 20

16 juil. 2013 à 14:50:37 via site

j'essaye de récupérer une photo, mais l'envoi est capricieux,
anyway on ne voit pas grand chose hors mis le fait qu'il répond directement no files found.

j'ai réessayé toute la proc entière et meme résultat.

n'est ce pas un pb de version du semaphore ou qq chose comme ca ?

Répondre
  • Posts de Forum 20

16 juil. 2013 à 15:02:24 via site

mais je ne trouve pas le tar.md5 sur le tel, j'ai fait une recherche de md5 il ne trouve rien

Répondre
  • Posts de Forum 20

16 juil. 2013 à 16:26:56 via site

ok mais peux tu stp me dire comment faire ?
j'ai fait la meme proc en chargant le md5 à la place du tar ... mais

<OSM> Enter CS for MD5..
<OSM> Check MD5.. Do not unplug the cable..
<OSM> Please wait..
<OSM> MD5 hash value is invalid
<OSM> nandroid.md5 is invalid.
<OSM> End...

Répondre
  • Posts de Forum 20

16 juil. 2013 à 17:04:56 via site

wooo dediou ca marche !!!
je ne sais pas pourquoi j'ai tout refait ca n'a pas marché, j'ai unmounté car la sdcard est cette fois arrivée mountée
ca n'a tjrs pas marché et j'ai réessayé une 3eme fois et ca a marché
reboot en cours .......


....


c'est ok !
Va comprendre charles !

Merci anyway pour ton temps Quentin

Répondre
  • Posts de Forum 62

16 juil. 2013 à 17:33:44 via site

Quand on flash le 4.2.2 le sdcard se transforme en dossier principal"0"
Cette cm10.1 utilise une structure de stockage unifié interne . Au premier démarrage de la rom, Le contenu de /sdcard (la mémoire interne) sera déplacé dans le dossier /sdcard/0. Aucune données ne devraient être corrompues. Une fois terminé, vous aurez un stockage interne unifié.
Le principe de flash est identique à chaque modèle,
1> Backup
2> copié la rom sur sd
3> se procurer les fichiers fastboot
4> cmd sous Windows
5> Flasher la rom via recovery installé
6> aller en mode fastboot
7> Fastboot erase cache
8> fastboot flash boot boot.img ( le boot.img est dans la rom)( fichier boot mi dans le dossier fastboot)
9> fastboot erase cache
10> reboot

— Modifié le 16 juil. 2013 à 17:46:41

Répondre
  • Posts de Forum 62

16 juil. 2013 à 18:27:50 via site

Seulement ici, on ne fait pas de update pour un téléphone pas près.
les fichiers fastboot sont différents
Il y a trois catégories
1> la rom stock
2> update via ota ou à flasher
3> la custom
ici on à,la non officiel

Répondre
  • Posts de Forum 20

16 juil. 2013 à 19:55:00 via site

hello ca marche bien,
par contre du coup je n'ai pas installé les google apps je suppose que je peux les installer apres coup sans avoir à réinstaller cyanogenMod ?

Répondre
  • Posts de Forum 62

17 juil. 2013 à 06:37:48 via site

oui pour les gapps
mais bien prendre les derniers 4.2.2

— Modifié le 17 juil. 2013 à 06:38:32

Répondre
  • Posts de Forum 20

17 juil. 2013 à 15:13:47 via site

hello good les apps sont installées aussi merci à tous les deux.
marche super ! effectivement plus fluide.
j'ai tout de même ajouté une SDcarde, mais je vois qu'on ne peut pas pousser les applis dessus seulement sur la SD "interne"
@bientot

Répondre
  • Posts de Forum 1

25 juil. 2013 à 20:51:54 via site

Bonjour,

Tout dabord, merci pour ce tuto.

J'ai tenté de suivre la procédure à la lettre, tout à l'air de s'être bien passé à un petit détail près.

Au point 9 : Choisissez reboot system now, mon galaxy s me reboot chaque fois sur le recovery :(

Est-ce que je fais quelque chose de faux ou y-a-t-il une manipulation à faire que j'aurais raté ?

Merci d'avance de votre réponse :)

Répondre
  • Posts de Forum 6

5 août 2013 à 20:46:10 via site

EDIT : Mon problème a été résolu, bien que maintenant j'en ai un autre. Pour info, la solution au problème précédent était de chercher une autre version du .tar. J'ai téléchargé le Semaphore_ICS_1.3.0s.tar.

L'installation fut chaotique, le back up data ne voulait pas se faire entièrement et le mode recovery quittait sans prévenir. J'ai fini par réussir à l'installer, et là c'est magnifique et fluide et (surtout) super rapide. Mais catastrophe, mon téléphone ne détecte plus ma carte SIM. :(

Ça marchait impeccablement avant, d'où mon incompréhension. La carte SIM marche sans problème sur un autre téléphone. Sous Cyanogen, on me demande pas mon PIN et impossible d'appeler/se connecter à la 3G. Aucun souci pour la wifi, par contre. Vous pensez qu'il faudrait réinstaller la rom ?...

Bonjour !

Tout d'abord, merci pour ce tuto, c'est lui qui m'a décidé pour me lancer dans cette installation. J'ai longuement vérifié si mon Galaxy S était bien adapté pour CyanogenMod et puis je me suis lancé.

Par contre, j'ai rencontré un gros problème, et je ne peux maintenant plus me servir de mon téléphone, ce qui m'angoisse un peu. :(

J'ai réalisé toute l'étape de l'installation du custom recovery sans problème jusqu'à la fin. En mode download, une fois qu'Odin a affiché "Pass!" j'ai redémarré le Galaxy S en Mode Recovery. Et au bout de dix secondes, je me suis retrouvé face à l'écran d'accueil du Galaxy S ("Galaxy S GT-I9000") qui se lance dans le vide, en boucle. Le téléphone ne se lance plus. C'est pareil s'il est branché ou débranché de l'ordinateur, et recommence quand j'enlève la batterie et que je l'enlève.

J'ai retenté la combinaison pour le mode Recovery et je tombe sur un écran noire, avec un série de code rouge dans le coin supérieur gauche et une icone Android vers le centre avec une bulle chargement et le texte, en jaune : "Forced Upload by Key Pressing". Là, l'écran reste bloqué sur cette image. Si je retente le mode Recovery, je retombe sur l'écran fixe du "Galaxy S".

Par contre, si je fais la combinaison en mode download, je retombe sur l'écran que j'avais lorsque j'étais connecté à Odin, avec le triangle jaune et le petit logo android avec une pelle. Si je le rebranche à l'ordinateur, il est reconnu par Odin. En fait le gros problème est que je ne peux pas accéder au mode Recovery.

Que dois-je faire ? Je me sens bête et je n'ai pas envie de dire au revoir à mon téléphone. :(

J'attends votre réponse, merci beaucoup !

EDIT : Dans le pire des cas, est-il possible de récupérer mon téléphone même si celui-ci perd toutes ses données ? Vu qu'il est toujours reconnu par Odin... Que je ne me retrouve pas avec une brique. :-/

— Modifié le 6 août 2013 à 00:52:41

Répondre
  • Posts de Forum 6

6 août 2013 à 12:07:02 via site

Non. Je n'ai aucun problème quand je met la carte SIM sur un autre téléphone, mais Cyanogen ne la reconnaît pas du tout. Sur Internet j'ai vu des solutions pour ce problème qui proposaient des manipulations avec le mode avion mais je n'ai rien eu.

De plus, le téléphone s'éteint tout seul aléatoirement de temps en temps, donc il est vraiment inutilisable. Je pense vraiment que l'installation s'est mal déroulée... Est-ce qu'il y aurait un moyen de refaire une installation avec (peut-être) une autre version ou alors de mettre une autre rom ?

Répondre
  • Posts de Forum 6

7 août 2013 à 12:01:27 via site

Quentin Ducreux
Au fait, tu as tenté les wipe ? Sinon, tu peux tout à fait reflasher ou flasher une autre rom, oui ! Tant que c'est compatible.

Que veux-tu dire par "tenter les wipe" ? Je suis extrêmement novice sur le sujet. :-/

Du coup, je recommence tout depuis le début, je l'ai éteint puis lancé en download mode, flashé avec Semaphore 1.3.0 et lancé ensuite en Recovery. Là, du coup, je refais le tuto depuis le début mais il bloque à l'étape back up, où il me met "Can't mount /Data !"...

Je commence un peu à désespérer, je veux juste retrouver un téléphone fonctionnel. :(

EDIT : J'ai recommencé l'installation depuis le début, Cyanogen s'est bien installé mais comme avant, je n'ai aucun réseau. Ma carte SIM n'est pas reconnue. Et elle marche sans problème sur mon vieux HTC Tattoo. Que faire ? :-/

— Modifié le 7 août 2013 à 12:16:10

Répondre
  • Posts de Forum 1 952

7 août 2013 à 14:07:36 via site

En mode recovery, tu peux faire wipe data, wipe cache partition, puis dans le menu advanced, wipe dalvik cache (pas nécessaire pour résoudre ce problème, mais vu que tu es là) et surtout fix permissions.

Répondre
  • Posts de Forum 6

7 août 2013 à 16:54:20 via site

Je viens de tenter ça. La manip s'est bien passée mais en redémarrant le téléphone, j'ai eu le même problème "Forced Upload by Key Pressing" qui s'est affiché, j'ai dû l'éteindre et le rallumer. Il s'est ensuite lancé et a affiché "Mise à jour d'Android" en chargeant pendant quelques temps.

Et encore une fois, pas de carte SIM reconnue, aucun réseau. Quand je vais dans à propos du téléphone, j'ai que dalle :

Réseau : Inconnu, intensité du signal : 0 dBm 99 asu, type de réseau mobile : UNKNOWN:0, état du service : hors service, Sans itinérance, numéro de téléphone inconnu...

C'est vraiment frustrant, d'autant plus que la wifi marche très bien et que je peux me servir du téléphone sinon. J'ai tenté avec une autre carte SIM, ça n'a rien changé.

Je ne sais vraiment plus quoi faire pour pouvoir de nouveau téléphoner. :-/

Répondre
  • Posts de Forum 6

7 août 2013 à 23:48:14 via site

Je pense que mon smartphone est bloqué Orange, oui. On me l'a donné il y a quelques mois et il a le petit logo orange dessus. Est-ce que ça veut dire qu'il faut que je le débloque ? (Je ne sais pas du tout comment on fait...) J'avais installé Cyanogen (une ancienne version) sur mon ancien téléphone bloqué Orange sans aucun souci.

Et comment est-ce qu'on vérifie son IMEI ? Je t'avoue totalement ignorer ce que c'est, malgré Google.

Répondre